<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Okta Usage Report Does Not Immediately Display New Users
Administration
Okta Classic Engine
Okta Identity Engine
Overview

This article explains a delay that occurs before a new user appears in the Okta Usage report. When a new user is created and an Okta Usage report is generated, the new user does not appear in the report immediately.


Admin Console  

Applies To
  • Okta User Report
  • New User
Cause

The delay is a result of the Okta Usage Report's migration to a new reporting framework.

Solution

Reports in the admin console reflect an approximate delay of 3-6 hours. This delay is not deterministic as it depends on the time required for jobs to run, which varies with data volume.

Recent changes to the reporting framework include:

  • The CSV file row limit is increased from 1 million to 5 million.

  • If a CSV file is generated in approximately three minutes, it downloads immediately from the admin console. If it takes longer, an email with a secure download link is sent.

Loading
Okta Usage Report Does Not Immediately Display New Users