Okta Smartsheet Push Group Fails With a Gateway Time-out Invalid JSON Error
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Overview
A Smartsheet push group fails due to an inactive account, invalid credentials, an invalid authentication token, or incorrect permissions within Smartsheet. Reauthenticating the API connection with a valid access token resolves the issue. When this occurs, the following error appears in the Okta dashboard:
Unable to update Group Push mapping target App group <appgroup>: Error while creating user group <usergroup>: Gateway Time-out. Errors reported by remote server: Invalid JSON: Unexpected character
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Smartsheet
- Provisioning
- Group Push
Cause
This error occurs when the account used to enable the provisioning integration in Okta meets one of the following conditions:
- The account is no longer active.
- The credentials used to create the API connection are invalid.
- The authentication token is invalid.
- The account permissions in Smartsheet are incorrect.
Solution
How is the "Invalid JSON: Unexpected character" Smartsheet push group error resolved?
Verify the permissions and status of the account used to create the API connection in Smartsheet, update the integration credentials in the Okta Admin Console, and retry the group push.
- On the Smartsheet side, verify the permissions and status of the account used to create the API connection.
- In the Okta Admin Console, navigate to Applications > Applications > Smartsheet > Provisioning > Integration, and click Edit.
- Enter the access token in the API Token field.
- Select Test API Credentials. Okta displays a verification message at the top of the screen if the test is successful.
- Select Save.
- Attempt the group push again.
