<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Okta RADIUS Error "The Okta RADIUS agent is running, but not currently accepting requests"
Okta Classic Engine
Multi-Factor Authentication
Okta Identity Engine
Overview

After installing the Okta RADIUS Agent on the server and configuring the RADIUS app in the admin console, the following error is seen in the Okta RADIUS Agent logs on the server: 

The Okta RADIUS agent is running, but not currently accepting requests. Please check if RADIUS apps have been configured in Okta.

 

Applies To
  • Okta RADIUS Agent
Cause

This error occurs because the UDP port used for configuring the RADIUS app in Okta is being used by another application/service on the server.

Here is where to configure which UDP port will be used to facilitate communication between Okta and the server:

RADIUS Application 

Solution

There are two methods to resolve this issue, depending on the operating system.

 

Windows

  • Option 1: Stop the conflicting process.

    1. Open the command line.

    2. Run the following command to find the process using the port, replacing <PortNumber> with the port number in conflict:

      netstat -aon | findstr :<PortNumber>
      
      
    3. Note the Process ID (PID) from the output.

    4. Open Task Manager and navigate to the Details tab.

    5. Locate the process with the matching PID and end the task.

  • Option 2: Use a different port.

    • Configure the RADIUS application in Okta to use a different, available UDP port.

 

Linux

  • Option 1: Stop the conflicting process.

    1. Run one of the following commands to find the process using the port, replacing <PortNumber> with the port number in conflict:

      sudo netstat -tulnp | grep :<PortNumber>

      If netstat is unavailable, use:

      sudo lsof -UDP:<PortNumber>
      
      
    2. Note the Process ID (PID) from the output.

    3. Run the following command to stop the process, replacing <PID> with the ID from the previous step:

      
      
      sudo kill -9 <PID>
      
      
  • Option 2: Use a different port.

    • Configure the RADIUS application in Okta to use a different, available UDP port.

 

After applying either solution, restart the system and verify that authentication is successful.

Loading
Okta RADIUS Error "The Okta RADIUS agent is running, but not currently accepting requests"