Okta Device Access Enrollment Fails to Recognize Existing FastPass Enrollment
Last Updated:
Overview
Enrolling Okta Device Access (ODA) after Okta Verify FastPass enrollment can result in the FastPass window appearing without a registered identity. This occurs when the ODA enrollment URL does not match the URL the user uses to enroll Okta Verify. Resolve this issue by adding both the standard and custom Okta domains to the Hosts and URLs values in the Single Sign-On (SSO) extension profile.
Applies To
- Okta Identity Engine (OIE)
- Okta Device Access (ODA)
- Okta Verify
- FastPass
- macOS
Cause
This issue occurs when the ODA enrollment URL does not match the URL the user uses to enroll Okta Verify. For example, the user enrolls Okta Verify using the standard Okta domain, while ODA enrollment uses the custom Okta domain.
Solution
How is the Okta Device Access enrollment failure resolved?
Resolve the enrollment failure by updating the Single Sign-On (SSO) extension profile in the mobile device management solution to include both the standard and custom domains.
- Add both the standard and custom Okta domains to the Hosts value when creating the SSO extension profile.
- Add both domains to the URLs value when configuring the SSO extension.
