Okta Changes Smart Single Quotes to Straight Single Quotes in User Profiles
Last Updated:
Overview
When an administrator modifies and saves a user profile containing a smart single quote (‘’), Okta automatically converts the character to a straight single quote (''). This conversion occurs even if the administrator updates a different attribute. This behavior does not affect smart double quotes (“”). This is expected behavior because Okta does not support smart single quotes.
Applies To
- Okta Identity Engine (OIE)
- User Profiles
- Lifecycle Management
Cause
Okta does not support the use of smart single quotes (‘’). When a profile update triggers a save action, Okta automatically sanitizes and converts the unsupported smart single quotes into standard straight single quotes ('').
Solution
Why does Okta convert smart single quotes to straight single quotes?
This is expected behavior. Okta does not support the use of smart single quotes (‘’). When an administrator updates a user profile, Okta automatically converts any existing smart single quotes to straight single quotes ('').
Currently, Okta allows the use of smart single quotes when creating a new user. However, Okta plans to restrict this functionality in a future update to prevent the use of smart single quotes entirely.
