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Okta ASA: Unable to Login with Error "Client's user and current user do not match"
Advanced Server Access
Okta Classic Engine
Okta Identity Engine
Overview

The client is getting the following error while logging in to the Advanced Server Access (ASA) team:

Client's user and current user do not match
 

Error message

Applies To
  • Okta Advanced Server Access
Cause

The login flow expects a different ASA username than the one the user has created a session for through Okta SSO. This can happen when a client has been enrolled to use multiple accounts for the same ASA team.

Solution
  1. Make sure the login request is using the expected account. This can be validated through "sft list-teams". The default value would be the one login flow is using. For example, in the below output, the user.2 will be used by the ASA login flow: 
    client@hostname~ % sft list-teams
    USERNAME          TEAM             URL                                      ID             STATUS                          
    user.1         asa_team-name     https://app.scaleft.com/v1               <id>           Never used                    
    user.2         asa_team-name     https://app.scaleft.com/v1               <id>           (default) Valid for 1h49m0s 
  2. Use "sft use <id>" if the username needs to be switched.
  3. Make sure no Okta session and ASA session exists. This can be validated through: 
    • Try to connect to the Okta user dashboard and logout.
    • Try to connect to https://app.scaleft.com/t/<asa-team-name>/home and logout.
  4. Log in to the ASA team again using "sft login," and make sure the account used for Okta login matches the one configured as the default in the client. 
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Okta ASA: Unable to Login with Error "Client's user and current user do not match"