Okta API Validation Error Occurs When Listing Identity Source Sessions
Last Updated:
Overview
An HTTP 400 error occurs when listing identity source sessions because the profile sourcing feature remains inactive in the Custom Identity Source application. Enable the profile sourcing feature in the application provisioning settings to resolve the error.
When attempting to set up a new Anything-as-a-Source (XaaS) Custom Identity Source application, Okta generates an HTTP 400 error code for the following API call:
GET /api/v1/identity-sources/{id}/sessions
(Okra specific) E0000001: Api validation failed: Identity Source App — Please enable profile sourcing feature.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Custom Identity Source Application
- Okta Integration Network (OIN)
- Identity Source Session API
Cause
The profile sourcing feature remains inactive in the corresponding Custom Identity Source application.
Solution
How is the profile sourcing feature enabled for a Custom Identity Source application?
Navigate to the application provisioning settings in the Okta Admin Console, enable the profile sourcing feature, and rerun the API call.
- In the Okta Admin Console, navigate to Applications > Applications.
- Select the Custom Identity Source application.
- Navigate to the Provisioning tab and select To Okta in the left settings menu.
- Click Edit.
- Enable the Profile Sourcing feature by selecting the Allow Custom Identity Source to source Okta users checkbox.
- Review and optionally configure the When a user is deactivated in the app option.
- Review and optionally configure the When a user is reactivated in the app option.
- Click Save.
- Rerun the List all identity source sessions API call to complete the request with an HTTP 200 OK success code.
GET /api/v1/identity-sources/{id}/sessions
