<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Okta AI Agents Are Not Visible When Using a Custom Admin Role
Okta Classic Engine
Okta Identity Engine
Okta For AI Agents
Overview

Okta AI Agents are not visible to users with Custom Admin Roles because custom roles are not currently supported for this feature.

To view Okta AI Agents, a user must have the Super Admin role. When a custom role and resource set are configured to grant access to manage AI Agents, assigned users are unable to view the AI Agents. Additionally, users with a Read-Only Admin role cannot view any AI Agent configurations.

 

Applies To
Cause

Okta does not currently support custom admin roles for AI Agents. The Manage agents permission within custom roles refers to Active Directory (AD) and Lightweight Directory Access Protocol (LDAP) agents rather than Okta AI Agents.

 

Solution

Why do users assigned a custom admin role to Manage Agents not see AI Agents in Okta?

Support for custom admin roles for Okta for AI Agents is currently on the product roadmap. Currently, the user must be a Super Admin to view Okta AI Agents.

Related References

 

Loading
Okta AI Agents Are Not Visible When Using a Custom Admin Role