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Error IDENTIFIER_NOT_FOUND when Creating a New Request Using the OIG API
Okta Classic Engine
Identity Governance
Okta Identity Engine
Overview

The OIG request API call returns the following error:

 

IDENTIFIER_NOT_FOUND

 

This error will arise if the requester user has not been assigned to the Okta Access Requests app.

 

Applies To
  • Okta Identity Governance
  • Access Requests

Cause

When making below OIG request API call on behalf of another user <userId>:

POST /governance/api/v1/requests

with body:

{
  "requestTypeId": "<requestTypeId>",
  "subject": "<subject>",
  "requesterUserIds": [
    "<userId>"
  ]
}

and the requester user <userId> has not been assigned to the Okta Access Requests app, the call will fail with the following error:

"errorCode": "E0000001",
"errorSummary": "Api validation failed: requesterUserIds/0 <userId> not found",
"errorLink": "E0000001",
"errorCauses": [
{
"domain": "governance",
"errorSummary": "<userId> not found",
"reason": "IDENTIFIER_NOT_FOUND",
"locationType": "body",
"location": "/requesterUserIds/0"
}
],
"errorId": "<errorId>"
},
Solution

To resolve the issue, 

  1. From the Admin console, navigate to Applications > Applications > Okta Access Requests.
  2. Assign the user to the application.
  3. Attempt to create the New Request via API again.

 

Related References

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Error IDENTIFIER_NOT_FOUND when Creating a New Request Using the OIG API