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Office365 Provisioning Error "Resource 'external-id' does not exist or one of its queried reference-property objects are not present." in Okta
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article goes in-depth about one of the errors for the Office 365 application that can be encountered during provisioning:

 

Automatic profile push of user <User> to app Microsoft Office 365 failed: Could not push profile for Office 365 user <username>, received error: Received response with error code Request_ResourceNotFound. httpStatusCode=404 errorCode=Request_ResourceNotFound errorMessage="Resource 'external-id' does not exist or one of its queried reference-property objects are not present." client-request-id=<microsoft-client-reqeust-id> request-id=<microsoft-request-id> timestamp=<date-of-event> method=PATCH url=https://graph.microsoft.com/v1.0/users/<user-external-id>

 

Applies To
  • Office365 
  • Provisioning
  • Okta Integration Network (OIN)
  • Okta Classic Engine
  • Okta Identity Engine (OIE)
Cause

This error message is thrown by Microsoft Graph API because the user with the specified external-id (or rather, resource-id on the Microsoft side) does not exist anymore on the Office 365 side.

This error occurs when the user object is deleted directly on the Office 365/Azure AD side, as opposed to being deactivated (and removed if using the Deprovisioning options for Office 365 ) using the provisioning feature Deactivate Users.

Solution

To fix this issue, please follow the steps below:

  1. Navigate to Okta Admin Console > ApplicationsApplications > Office 365 app.
  2. On the Assignments tab, search for the affected user:
    • If the user is assigned as an individual: Un-assign and re-assign the user to the Office 365 application.
      • Should the user already have an existing account on the Office 365 side with a different "external-id", the re-assignment will match that user to their Okta counterpart.
      • If the user does not exist anymore, Okta will create a new user, provided the Create Users provisioning option is enabled.
    • If the user is assigned through a group:
      1. Search for the user in the Assignments tab.
      2. Click on the "Blue Pencil Icon" next to the user to open the Edit User Assignment window.
      3. At the top of the Edit User Assignment window, in the Assignment master section, select Administrator.
      4. Scroll down and save to convert the assignment to an individual assignment, then unassign and reassign the user.

Now the provisioning error should be gone, without having to retry the task in Admin Console > Dashboard > Tasks.

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Office365 Provisioning Error "Resource 'external-id' does not exist or one of its queried reference-property objects are not present." in Okta