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Office 365 Provisioning "Unable to read Office 365 directory sync for the company, received error"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

The admin reporting the Office 365 provisioning task failed with the below provisioning error starting in late March 2025. 

 

Unable to read Office 365 directory sync for the company, received error: com.microsoftonline.provisioning.IProvisioningWebServiceMsolConnectInternalServiceExceptionFaultFaultMessage: Could not load file or assembly 'Microsoft.IdentityModel.Protocols.SignedHttpRequest, Version=8.0.2.0, Culture=neutral, PublicKeyToken={PUBLIC_KEY_TOKEN_ID}' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040), user: {O365_APP_USERNAME}



Error from System log

Applies To
Cause

This O365 provisioning issue is caused by ongoing MSOnline PowerShell deprecation on customers' Microsoft platforms. This causes Okta to be unable to reach the MSOnline endpoint during the Microsoft Office 365 provisioning task. 

For full details, please read the Microsoft Announcement post and contact the Microsoft Support team for additional clarification.

Solution

To avoid/remedy the Okta O365 provisioning error, please follow the below steps:

  1. Apply the Knowledge Base's solution to all of the impacted Okta O365 app instances with provisioning enabled.
  2. Navigate to Okta Admin Console > Dashboard > Tasks > and retry the failed O365 provisioning/app assignment task with the mentioned error. 

 

Related Reference

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Office 365 Provisioning "Unable to read Office 365 directory sync for the company, received error"