<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Okta Access Gateway: EBS Java Applet Fails to Load With a "General Exception" Error

Access Gateway

Overview

An EBS application is configured in Okta Access Gateway (OAG), but when launching a Java applet (downloaded the jlnp file), it fails to load with the following application error:

 

General Exception

NullPointerException: null

 

Error_Screenshot

Applies To

  • Okta Access Gateway (OAG)
  • Oracle E-Business (EBS)

Cause

This is an authentication-related issue due to the Java applet running separately from the browser, where it does not share the OAG session and does not support SAML.

Solution

NO_AUTH exceptions need to be made in the application's advanced policies to allow Java Web Start to communicate back to EBS without needing an Okta Security Assertion Markup Language (SAML) session.

  1. Create three Protected policies for the following resources:
    • /OA_JAVA/
    • /forms/lservlet
    • /forms/frmservlet
  2. Add the following directive to each of the above policies:
    if ( $http_user_agent ~ "^.*Java.*$") {
    set $policy_type "NO_AUTH";
    }
Loading
Okta Support - Okta Access Gateway: EBS Java Applet Fails to Load With a "General Exception" Error