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No Access to Flows or Connections Tabs in Workflows Console
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

When trying to access the Workflows Console, only the Home and Templates tabs are at the top of the page, and Flows and Connections are missing, which prevents access to review and create Flows

Example screenshot of issue experienced where only the two tabs/links show at the top of the page: 

Workflows

 
 
Cause

There are two common causes for this:

  1. Provisioning Error
  2. Role not assigned to user within Workflows Console


Cause 1: Provisioning Error

  1. After Role Based Access Control (RBAC) for Workflows is enabled, any super admins already assigned to the Okta Workflows app immediately transition to the Unassigned User role. This means that these existing super admins do not have any privileges in Okta Workflows until these accounts are provisioned.
  2. Verifying if this is a Provisioning Error: There would be a provisioning error in the Admin Console Tasks Dashboard or in Admin Console > Apps > Apps > WorkflowsAssignments tab.
Workflows

Cause 2: Role not assigned to user within Workflows Console

    1. With RBAC enabled for Workflows, the User is assigned and provisioned to the Okta Workflows app. However, they are not assigned a Role(permission) within Workflows Console > Settings > Role Assignments.
      • Here is an example where there is no Role Assignment granted at the user level within the Workflows Console. 
        • NOTE: While this is an example at the user level, if Group Push is configured, the user may be able to be assigned a Role via Group.
    Workflows
     
    Solution

    Solution for (Cause 1) Provisioning Error

    1. If there is a Provisioning Error like seen in Cause 1 above, there are a couple of items available to try to resolve:

      1. Manually Provision user (2 options):
        1. Un-assign and Re-assign the user(s) to the Okta Workflows application from Admin Console > Apps > Apps > Workflows > Assignments tab.
        2. If available under Admin Console > Apps > Apps > Workflows > Assignments tab, manually provision the user by clicking Provision User.
    Workflows
    1. Review the Provisioning error for the user(s) and address any error that persists.

     

    Solution for (Cause 2) when a Role is not assigned to a user within Workflows Console

    1. If there are no provisioning errors, ensure that the user has a Role (permission) assigned to them within Workflows Console > Settings > Role Assignments.


    Related References

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    No Access to Flows or Connections Tabs in Workflows Console