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Ninja RMM SAML Integration Error During IdP Flow Login
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

This article addresses a common issue experienced by users attempting to initiate a Security Assertion Markup Language (SAML) integration between Okta and Ninja RMM. The issue occurs when users try to open the application and encounter an error message that reads:

No content to map due to end-of-input at [Source: (String)""; line: 1, column: 0]


The error message indicates that the SAML workflow is not supported in the particular manner being attempted.

Applies To

This issue affects organizations using Okta as an Identity Provider (IdP) and Ninja RMM as a Service Provider (SP) in a SAML configuration, where the IdP-initiated sign-on is being used.

Cause

The error is triggered by the incompatibility of the SAML workflow. Ninja RMM's SAML integration only supports Service Provider (SP) initiated workflow. Hence, when an Identity Provider (IdP) initiated sign-on is attempted, the error message is generated.

Solution

To resolve this issue, modify the SAML integration process to align with Ninja RMM's supported SP-initiated login flow. 

If an IdP-initiated flow is needed, create a bookmark app to simulate an IdP-initiated authentication flow.

This change should resolve the error message and allow for a successful login. It is recommended to reach out to Ninja support for assistance if required.

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Ninja RMM SAML Integration Error During IdP Flow Login