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New User Creation in Okta Fails Due to Password Requirements Not Being Met even though the Password Matches the Requirements
Administration
Okta Classic Engine
Okta Identity Engine
Overview

New user creation in Okta fails because the password requirements were not met, even though the password meets the requirements. 

Applies To
  • Password Policy 
Cause

The password policy also takes into account the rules set for the password policy, specifically, if the condition defined for a user's IP matches one of the network zones. This means that the rule will be applied to users trying to change the password from a network zone. For example, allow users to change passwords when they are in a network zone, such as a corporate network. See screenshot below:

Edit Rule 

 
Solution

In addition to the password complexity requirements, adjust the IP zone in the rule in the password policy so it meets the requirement for the user to be created.

In order to review the Network zones defined:

  1. Navigate from the Admin Console to Security > Networks
  2. Click on the pencil icon to edit a zone.

Networks

  1. Click Save after making the necessary amendments.  
 
 
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New User Creation in Okta Fails Due to Password Requirements Not Being Met even though the Password Matches the Requirements