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Microsoft Office 365 API Integration Error "AADSTS90002: Tenant not found. Check to make sure you have the correct tenant ID and are signing into the correct cloud"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When enabling Microsoft Office 365 API integration by clicking on Authenticate with Microsoft Office 365, the following error appears:

 

AADSTS90002: Tenant '<DomainName>.onmicrosoft.com' not found. Check to make sure you have the correct tenant ID and are signing into the correct cloud. Check with your subscription administrator, this may happen if there are no active subscriptions for the tenant.

 

AADSTS90002

Applies To
  • Microsoft Office 365
  • Provisioning
Cause

This error occurs because the Microsoft Tenant Name is incorrect in the Applications > Microsoft Office 365 > General tab.

Solution

The following video and steps show how to fix the Microsoft Office 365 API Integration error:


 

  1. Open an incognito window in your browser and log in to the Okta tenant.
  2. Go to Okta Admin Console, navigate to Applications > Microsoft Office 365 > General, and click Edit. Enter the correct Microsoft tenant name and save the change. 
  3. Then navigate to Microsoft Office 365 > Provisioning > Integration > check Enable API Integration.
  4. Click Authenticate with Microsoft Office 365. The Microsoft Azure login page appears.
    1. Log in to the Microsoft Azure account.
    2. Read and accept the requested permissions.
    3. Upon accepting the scopes in the Microsoft Azure portal, the page is redirected back to Okta.
  5. Enter the Office 365 Global Administrator credentials.
  6. Click Test API Credentials.
  7. A message confirming successful authentication is generated. Click Save.
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Microsoft Office 365 API Integration Error "AADSTS90002: Tenant not found. Check to make sure you have the correct tenant ID and are signing into the correct cloud"