MFA for RDP Always Prompts as High Risk Number Challenge
Last Updated:
Overview
Applies To
- MFA for RDP
- RDP
- ADFS
- Multi-Factor Authentication (MFA)
Cause
This behaviour is to be expected because RDP, as well as ADFS for that matter, have an embedded browser that they use and that browser does not save the user sessions.
Solution
The only way to eliminate the number challenge from the RDP and ADFS plugins is to eliminate the number challenge prompt. Setting the Number Challenge for Okta Verify Push to "Never" is recommended, as this is a tenant-wide setting.
