<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

macOS Users with SSO Extension Profile Do Not Receive Device Lifecycle Messages in Safari on Big Sur and Earlier

Multi-Factor Authentication
Okta Identity Engine

Overview

This article describes an issue where users on macOS devices configured with an SSO extension profile do not receive Okta device lifecycle messages. This problem specifically affects Safari users on macOS Big Sur and earlier versions.

Applies To

  • macOS 
  • Safari
  • Okta Device Lifecycle
  • Okta Identity Engine (OIE)

Cause

Okta device lifecycle messages are not available to Safari users on macOS Big Sur and earlier versions when an SSO extension profile is utilized on the device. This limitation prevents the delivery of these messages in such configurations.

Solution

Upgrade the OS to Monterey (12.0) or later, as the latest release is recommended. 

 

Related References

Loading
Okta Support - macOS Users with SSO Extension Profile Do Not Receive Device Lifecycle Messages in Safari on Big Sur and Earlier