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Login to SharePoint Online Fails after Federating with Okta
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Single Sign-On
Overview

After federating a Microsoft Office 365 (O365) tenant with Okta, users attempting to login to SharePoint Online may fail with the following error:

 

Application with Identifier https://<tenant>.onmicrosoft.com.sharepoint.com was not found in the directory.

 

Microsoft Office 365 Error  

 

 

Applies To
  • Microsoft Office 365 (O365)
  • Sharepoint Online
  • Federation
Cause

The Microsoft Tenant Name in the O365 integration of Okta is configured with the full tenant URL rather than using just the subdomain.

App Settings

 

Solution

Remove the .onmicrosoft.com domain suffix by following the below steps:

  1. Open the Okta Admin Dashboard.
  2. Navigate to Admin > Applications > Applications > [O365].
  3. In the O365 integration, click General.
  4. In the App Settings section, click Edit.
  5. Update the Microsoft Tenant Name to use just the prefix. For example, if the Microsoft tenant is acme.onmicrosoft.com, enter acme.

App Settings

  1. When finished, click Save.
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Login to SharePoint Online Fails after Federating with Okta