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"Login information is incorrect" Error When Authenticating to Sage Intacct SAML Application
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

When attempting to authenticate to the Sage Intacct SAML app, users face the error Login information is incorrect, and neither their Company ID nor their User ID is populated.

Identity Provider (IdP) SAML flow: Users immediately face the error when clicking on the app tile.
Service Provider (SP) SAML flow: Users are redirected to Okta for authentication, and, after successful authentication with Okta, they are faced with the error.

Applies To
  • SAML 2.0
  • Single Sign-On (SSO)
Cause

There could be multiple reasons for this error; however, the most common cause is a misconfiguration, either on the Okta side or the Sage Intacct admin side. This is why it is best to collect a HAR and see the SAML payload to narrow down the possibilities.

Solution

Here are a few of the most common solutions for this error:
 

  • Misconfigured Company ID:
    1. Access the Okta Admin Console.
    2. Navigate to Applications > Applications.
    3. Search for the Sage Intacct app > open it.
    4. Under the General tab > Make sure the Company ID is correctly added. The company ID can be found under the Company Information on Sage Admin Console.
  • Misconfigured Federated SSO user ID:
    1. Access the Okta Admin Console.
    2. Navigate to Applications > Applications.
    3. Search for the Sage Intacct app > open it.
    4. Under the Sign On tab > Make sure the Federated SSO user id is selected based on the selection made on the Sage Admin Console side. If the Federated SSO user id is supposed to be the email prefix, then select Username. If the Federated SSO user ID is supposed to be the whole email, select Email.
  • Incorrect certificate pasted into the app:

When configuring the SSO on the application side, please enter the Issuer URL, Login URL and Certificate from Okta. For copying the certificate, make sure to include the following:

  • BEGIN CERTIFICATE
    
  • END CERTIFICATE
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"Login information is incorrect" Error When Authenticating to Sage Intacct SAML Application