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Limitations and Potential Workaround for Group-Based IdP Routing Rules in Okta
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

This article addresses the current limitations of configuring Identity Provider (IdP) Routing Rules in Okta based on group membership. While direct group membership matching is not currently possible, a workaround is presented below involving user attributes.

Applies To
  • IdP Routing Rules based on group membership
  • Identity Management
Cause

In the existing Okta system, IdP Routing Rules are triggered during the authentication flow. However, at this stage, the user's group memberships are not recognized, preventing the direct application of group-based routing rules.

Solution

While Okta currently does not support direct group membership matching in IdP Routing Rules, use the following workaround with user attributes:

  1. Configure a group rule to assign users with a specific attribute value to a group.
  2. Edit the routing rule to match the user attribute and its value.
    • For instance, users with the "Title" attribute set to "Manager" get assigned to the "Managers" group. Adjust the routing rule so that it matches the "User attribute, Title Equals Manager" condition. Although there is no direct connection between the "Managers" group and the Routing Rule, all users with the "Manager" title who also belong to the "Managers" group will be routed accordingly.

Related References

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Limitations and Potential Workaround for Group-Based IdP Routing Rules in Okta