LaunchDarkly Provisioning Error "The following email addresses belong to members of other LaunchDarkly accounts"
Okta Integration Network
Overview

LaunchDarkly provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app LaunchDarkly failed: Error while creating user <username>: Bad Request. Errors reported by remote server: The following email addresses belong to members of other LaunchDarkly accounts: <email addresses>

 

Applies To
  • LaunchDarkly
  • Provisioning
  • Error
Cause

The provided user email value is already taken, and the email address belongs to a member of another LaunchDarkly account. Only one email address may be associated with a LaunchDarkly account. Attempting to provision the same email address into multiple accounts will fail.

Solution
  1. Please open a support case with LaunchDarkly support. They will be able to assist in checking if the user email is already taken by a member of another LaunchDarkly account and fix the issue. This error could also be generated if the user has a self-subscribed free trial account with this email address.

  2. After confirming that the issue is fixed on the LaunchDarkly side, attempt the user provisioning again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks. Tasks Page 

  3. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

 

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