"Internal Server Error" Occurs When Accessing the Identity Providers Tab in Okta
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Overview
An internal server error occurs when accessing the Identity Providers tab in Okta due to a misconfigured Okta Integration Identity Provider (IdP). Contacting Okta Support to enable a specific feature, then removing the misconfigured IdP, resolves the issue. When this failure occurs, Okta generates the following error message:
Error
Internal Server Error
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Identity Providers (IdP)
Cause
A misconfigured Okta Integration IdP exists in the environment and prevents the Identity Providers page from loading correctly.
Solution
How is the "Internal Server Error" resolved?
Contact Okta Support to request the enablement of a feature by referencing this article. Once Okta Support enables the feature, remove the misconfigured Identity Provider.
- Go to the Identity Providers tab in the Okta Admin Console.
- Locate the misconfigured Okta Integration IdP.
- Deactivate the misconfigured IdP.
- Delete the misconfigured IdP.
NOTE: The misconfigured Okta Integration IdP can not be modified; it can only be removed.
