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IdP Created with Identity Providers API Returns "ACTIVE" Status
Okta Classic Engine
Okta Identity Engine
API Access Management
Overview

When a new Identity Provider (IdP) is created using the Identity Providers API, the status returns "ACTIVE" even when setting the status to "INACTIVE" in the request body: 

New IdP via API

 

Applies To
  • Identity Providers API
  • Identity Provider (IdP)
Cause

The status for a new IdP will always be "ACTIVE" regardless of setting the status to "INACTIVE" in the request body.

Solution

As a newly-created IdP cannot be used until a routing rule is created for the IdP, there is no negative consequence for creating it with an "ACTIVE" status.

To set the status to "INACTIVE", a second POST call can be made with the IdP ID to deactivate it, which will then set the status to "INACTIVE":

Deactivate IdP

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IdP Created with Identity Providers API Returns "ACTIVE" Status