How to Update Office 365 to Use a New Okta Custom Domain
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Overview
After a new custom domain is configured in Okta, the Office 365 application may continue to redirect users to the original, default Okta domain URL instead of the new custom domain.
This article explains how to update the Microsoft Office 365 application to redirect users to the new custom domain when they log in.
Applies To
- Okta Custom Domains
- Microsoft Office 365
- Okta Classic Engine
- Okta Identity Engine (OIE)
Cause
The Microsoft Office 365 application settings in Okta do not automatically refresh to use a new custom domain. The configuration must be manually updated to recognize and apply the new domain for user redirection.
Solution
To apply the update for Microsoft Office 365 to use the newly added custom Okta domain, follow these steps:
- In the Okta Admin Console, navigate to Applications > Applications.
- Select the Office 365 application.
- Go to the Authentication tab (or Sign On).
- Select Edit.
- Select Manage verified domains > Next.
- Select Save. This triggers a refresh for all the Office 365 domains to use the new custom domain.
NOTE: If the custom Okta domain is ever removed, repeat this process to revert the Office 365 integration back to the default Okta domain. Failure to do so will result in users being redirected to a nonexistent domain, triggering a 404 error code.
