レート制限引き上げのリクエスト方法
Administration
Okta Classic Engine
Overview

この記事では、レート制限の引き上げをリクエストする方法と、そのリクエストとともに提供する必要がある情報について説明します。

レート制限の引き上げは、サポートケースを開いて特定のOkta APIエンドポイントのレート制限を引き上げることでリクエストできます。リクエストは、レート制限の引き上げが必要となる少なくとも15営業日前までに提出する必要があります。送信されたリクエストは、Oktaで十分に確認され、許可または拒否されます。リクエストによっては審査に時間がかかる可能性があるため、できるだけ余裕を持ってリクエストを送信することを強くお勧めします。

リクエストは、次のお客様に対して送信できます。

  • Workforce Identity Cloud(WIC)のお客様
  • Customer Identity Solution(CIS)のお客様

各リクエストは個別に評価されます。以前のリクエストが承認されたからといって、今後の承認が保証されているわけではありません。Oktaは、各リクエストがシステムパフォーマンスおよび利用可能な容量に与える影響を、提出時に評価します。

注:承認された場合、APIトークンが100%に達しない限り、バーストレート制限(BRL)の形式での引き上げは有効になりません。

ユーザー、グループ、またはアプリの作成や変更などの管理作業に伴うエンドポイントのレート制限引き上げが承認される可能性は低いです。これは複雑さが増すことが関係しているためです。

Dynamic ScaleまたはWorkforce Multipliersでカバーされているエンドポイントのリクエストを行った場合、Oktaはそのリクエストを拒否し、Dynamic Scaleの購入またはWorkforce Multiplierの増加について、アカウントチームと相談することをお勧めする場合があります。通常、これは次の場合に発生します。

  • 1暦年の間に複数回、一時的なレート制限の引き上げがリクエストされた。
  • デフォルトのレート制限の5倍以上のレート制限の引き上げがリクエストされている(例:1分あたり1,000件から5,000件のリクエスト)。
  • 恒久的なレート制限の引き上げがリクエストされている。 
Applies To
  • レート制限
  • レート制限に関する警告
  • レート制限違反
  • Okta Classic Engine
Cause

Oktaが提供するデフォルトのレート制限よりも高いレート制限が必要となるため。

Solution

以下の情報を提供してください。正確な情報が提供されない場合、リクエストの遅延や拒否につながる可能性があります。

注:Oktaは、サービスを維持するプロセスにおいて、予告なしに制限を増減する場合があります。Oktaは、悪用、スパム、サービス拒否攻撃などのセキュリティ上の問題を防ぐために、その他の機能をレート制限する権利を留保します。
Organization情報:

  • Org名:
  • Org URL:

リクエストの詳細:

  • 開始時刻:
  • 終了時刻:(恒久的なリクエストの場合は、終了時刻を[恒久的]にしてください)
  • レート制限の引き上げ:
    • 正確なAPI URI:(例:api/v1/usersではなくapi/v1/users/factors/{factorsId}
      • 操作:読み取りまたは書き込み(データは読み取り専用か、またはデータの作成や更新を試行するか)
      • 目標のレート制限:
      • 目標のレート制限の根拠:
  • 引き上げに対するビジネス上の正当な理由:恒久的なリクエストの場合は、一時的なリクエストがオプションとならない正当な理由を提供してください。

  • 追加情報:レート制限の引き上げリクエストを正当化する追加のコンテキストまたは証拠(例:認証フロー、プロセスフロー、リクエストの量、パフォーマンステストの結果)。

  • 該当する場合:

    • ユーザーの作成でイベントがいくつ生成されますか。

    • ユーザー名/パスワードはシステムから送信されますか。

    • 送信される場合、形式はMD5ハッシュまたはプレーンテキストですか。

    • ユーザーがSMSまたは音声の要素に登録されますか。登録される場合、それぞれいくつですか。

    • 1秒あたりのSMSトラフィックは何ですか。

    • 1時間あたりいくつのSMS登録が送信されることが予想されますか。

    • 1時間あたりのSMS検証はいくつですか。

    • SMSはどの国に送信されますか。

    • 組織は、ほとんどのユーザーが拠点を置く国以外の国にプロキシサーバーを構成していますか?

    • グループの割り当てがありますか。ある場合、いくつですか。

    • アプリの割り当てがありますか。ある場合、いくつですか。

    • このイベント中に使用されるワークフローを説明できますか。

注:引き上げを承認する前に、Oktaサポートから追加のドキュメントやエンドポイントの使用状況(エンドポイントあたり7日間で最低1,000件のリクエスト)を要求される場合があります。エンドポイントのレート制限が過去12か月間に3回以上引き上げられた場合、そのエンドポイントに対するレート制限の引き上げが拒否される可能性があります。このような場合は、指定されたアカウントチームに動的スケールについて相談する必要があります。リクエストを送信する際に、ピーク時のトラフィックメトリクスを含む包括的な使用状況の履歴データと、レート制限引き上げの必要性を正当化する詳細なビジネスケースを提供してください。 

 

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