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Prevent Setting Blank or Null Password via Users API Call within Okta
Administration
Okta Classic Engine
Okta Identity Engine
Overview

This article clarifies whether the Users API is able to save null or blank passwords. An administrator is attempting to update a user's password using one of the following methods, which results in the user's password being set to a blank or null value:

PUT api/v1/users/<USER_ID>

POST api/v1/users/<USER_ID>

API call 

 

Applies To
  • Users API
  • Adding a blank or null password
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
Cause

The ability to save blank or null passwords to users via an API call is allowed because the PREVENT_SETTING_BLANK_PASSWORD_ON_USER_UPDATE feature is disabled. When this feature is disabled, the administrator is able to save blank or null passwords to users via an API call.

Solution

Contact Support to enable the feature PREVENT_SETTING_BLANK_PASSWORD_ON_USER_UPDATE.

After the feature is enabled, the result prevents the saving of blank or null passwords.

Postman

Related References

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Prevent Setting Blank or Null Password via Users API Call within Okta