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Slack Provisioning Error "Automatic provisioning of user <username> to app Slack failed: User account is inactive"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article will go over resolving the following error when provisioning a user to Slack:

Automatic provisioning of user <username> to app Slack failed:

 

User account is inactive

 

Slack assignments

 
Applies To
  • Slack provisioning
  • Okta Integration network
  • Slack Provisioning > To App > Deactivate User is disabled while the matching Slack user is an inactive account in Slack Workspace
Cause
There are two possible causes:
  1. When the 'Deactivate User' checkbox is disabled in the Slack Application Provisioning settings
  2. When the user is Inactive within the Slack environment
Solution

Follow the steps or video below:


 

  1. Navigate to Okta Admin Console > Applications > Slack > Provisioning > To app configuration, click on the Edit button. 
  2. Check/Enable the Deactivate User checkbox. 
  3. Click Save.
  4. Navigate to Okta Admin Console > Dashboard > Tasks, and retry the selected failed Slack assignment. 
  5. The Slack app assignment should be completed without previous errors this time. 
  6. Verify in Slack Admin Console > Manage Members that the target provisioned Slack user account has been reactivated. 
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Slack Provisioning Error "Automatic provisioning of user <username> to app Slack failed: User account is inactive"