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How to Find x-okta-request-id in Network Logs, Okta System Logs, or Postman
API Access Management
Overview

The purpose of the article is to help identify the location of the x-okta-request-id in the network logs.

Applies To
  • x-okta-request-id
  • RequestId
  • Troubleshooting
  • Error
  • Network Logs
  • Developer Console
Cause

If an error occurs or there is irregular behavior with the calls, the support team may request the x-okta-request-id to investigate further.

Solution

The RequestId can be found in multiple locations, one of them in the browser, and the other is in Okta System Logs:

  • To find the x-okta-request-Id of a specific call in the browser, navigate to the Developer Console > Network > click on the targeted call > Headers.

x-okta-request-Id

  • To find the RequestId in System Logs, navigate to Okta Dashboard > Reports > System Logs > DebugContext > DebugData.

RequestId

    • The request ID is used for debugging, as mentioned in this developer documentation.
    • The x-okta-request-id found in the browser can be used for further debugging in System Logs:
      transaction.id eq “xxxe9abcb714cb4e2912822bc146"  OR debugContext.debugData.requestId eq “xxxe9abcb714cb4e2912822bc146"

System Log

  • To find the x-okta-request-id for a specific call in Postman, click the Console icon located in the bottom-left corner of the window. In the console log, expand the desired call that should be inspected, and then expand the Response Headers section to locate the x-okta-request-id, as illustrated in the provided screenshots:

Console icon

x-okta-request-id for a specific call in Postman

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How to Find x-okta-request-id in Network Logs, Okta System Logs, or Postman