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Group Rules and Custom User Profiles
Lifecycle Management
Okta Classic Engine
Okta Identity Engine
Overview

Issues with previewing or saving the rule when creating group rules for users who are assigned a custom user profile.

Applies To
  • Group Rules
  • User Profiles
Cause

Okta Group Rules are not executed for non-default user types. This is the case whether Admins use the preset conditions in the UI or the Okta Expression Language option.

In either case, if the expression is not valid for the Default Type, the rule cannot be saved or previewed, even if the user being previewed is of the custom type.

If the rule references a property that exists only for the Default Type and not the Custom Type, then when it is evaluated for a custom user (for previewing or for determining group memberships), the expression will treat the property as having a value of null.

 

Solution

Converting the users in question to the default Okta user type will resolve this issue. 

To convert users to the default Okta user type, please follow the steps below: 

  1. In the Admin Console, go to Directory > People.
  2. Optional. Select a user type in the User Type list to filter the people list by a specific user type.
  3. Select a person in the Person & username column.
  4. Click Change at the top of the user profile screen.

test user

  1. In the Choose user type list, select the User type.
Change user type
  1. Verify the attribute values for the user are correct.
  2. Optional. Update any attribute values that were not transferred.
  3. Scroll down and click Change user type.

attributes

  1. The user type updates at the top of the user profile screen.

Related References

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Group Rules and Custom User Profiles