PagerDuty Deprovisioning Error "Error while deactivating user: null (0): The user cannot be deleted as they have 1 incident."

Okta Integration Network
Okta Classic Engine
Okta Identity Engine

Overview

PagerDuty deprovisioning flow fails with the following error visible in the Okta dashboard:

 

An error occurred while deprovisioning this account from the app.
Error while deactivating user [user]: null (0): The user cannot be deleted as they have 1 incident. Please resolve the following incident to continue

 

Error Message

Applies To

  • PagerDuty
  • Provisioning
  • Error

Cause

In PagerDuty, the User Offboarding settings (found in Configuration > Account Settings > User Offboarding) are set to Fail the removal of any user with assigned incidents. PagerDuty users cannot be deleted from Okta, and de-provisioning will fail with this error.

Solution

  1. Refer to this PagerDuty Okta SSO Integration Guide.  
    • NOTE: If an account has the offboarding feature, to delete PagerDuty users via Okta, the User Offboarding settings must be in place. (found in Configuration > Account Settings > User Offboarding) set to Automatically restart incidents on their escalation policy.

"Automatically restart incidents on their escalation policy" option

    • If this is set to Fail the removal of any user with assigned incidents, it will not be possible to delete users via Okta.
  1. Log in to the PagerDuty account as an Administrator. Navigate to Account Settings > User Offboarding and set it to Automatically restart incidents on their escalation policy.
  2. Afterward, attempt to deprovision the user again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed deprovisioning tasks should appear under Tasks.
  3. After identifying the failed task for the user that should be retried, click Retry Selected
     

Related References

Recommended content

No recommended content found...