Google Workspace Provisioning Error "Failed to verify that the user exists. javax.ws.rs.BadRequestExecption: HTTP 400 Bad Request"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Google Workspace provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Google Workspace failed: Failed to verify that the user exists. javax.ws.rs.BadRequestException: HTTP 400 Bad Request

error message 

Applies To
  • Google Workspace
  • Provisioning
  • Error
Cause

This error is generated because the Google Workspace credentials used for creating the API connection are invalid. 

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > Google Workspace > Provisioning > Integration > click the Edit button.
  2. Click Re-authenticate with Google Workspace.

    Re-authenticate with Google Workspace button 
  3. Enter Google Workspace Admin account credentials:

    • Enter Admin username.
    • Enter Admin password.
    • Review the list of permissions Google will grant Okta to perform in the Google Workspace tenant. If acceptable, click Allow.
  1. Back on the Provisioning page in Okta, a message confirming successful authentication will be displayed. Click Save.

  2. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks menu

  1. After locating the failed task for the user that should be retried, click on Retry Selected.

 

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