Getting "SSO_001[2d8231f4]" Error when Authenticating to Udemy (SAML)
Single Sign-On
Okta Identity Engine
Overview

Users are getting the below error when authenticating to Udemy Business using SAML SSO:

 

Oops

We're unable to complete the authentication process with the Identity Provider (IdP). You can try to connect to the application again later or contact an administrator.

SSO_001[2d8231f41

 

Applies To
  • Okta Integration Network (OIN)
  • Udemy Business
  •  Security Assertion Markup Language (SAML)
  • Single Sign On (SSO)
Cause

The authentication error SSO_001[2d8231f41] suggests a possible misconfiguration during the initial setup with Okta Identity Provider (IdP).

Solution

To address this issue, the following steps will verify that the settings are correctly configured in Okta:

  1. In the Okta Udemy Business app, navigate to Sign On > Edit > SAML 2.0 > Default Relay State.
  2. Validate that the Default Relay State is configured as https://pingone.com/1.0/d905a6ca-adf9-45e2-9b9d-0d6485f27206

Default Relay State

 

  1. In the Okta Udemy Business app, navigate to Sign On > Edit > Advanced Sign-on Settings > Audience URI (SP Entity ID).
  2. Validate that the Audience URI (SP Entity ID) is configured as PingConnect.

Audience URI

 

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