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Error "Errors reported by remote server: missing required field" During Kandji Provisioning in Okta
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Whenever a user is assigned to the Kandji application in Okta, the following error is seen:

 

Automatic provisioning of user <username> to app Kandji SCIM App failed: Error while creating user <username>: Bad Request. Errors reported by remote server: missing required field

Applies To
  • Provisioning
  • Kandji
  • User Lifecycle Management
  • Okta Classic Engine
  • Okta Identity Engine (OIE)
Cause

As with most provisioning errors, they are reported by the remote server and include an error message relevant to the scenario.
In this case, the error occurs because the user misses a required value when the application is provisioning.

Solution

As per Kandji SCIM Directory Integration, the attributes required for the SCIM integration are:

  • User attributes:
    • userName
    • active
    • emails.value
  • Group Attributes:
    • displayName

  Kandji attributes required  


To fix this error:

  1. Go to the Kandji application in Okta by searching the top-middle bar or by going under Applications > Applications menu.
  2. Under the Assignments tab, click the pencil icon for the user experiencing the error (the same steps apply to group attributes).

Assignments

  1. Verify that all required attributes are populated.
  2. Go to Dashboard > Tasks > Search by application > Kandji.
  3. Select all failed tasks, then click Retry Selected.
  4. Refresh the page and check if the task has been cleared.


NOTE: If the issue persists, please engage Kandji support.
 

Related References

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Error "Errors reported by remote server: missing required field" During Kandji Provisioning in Okta