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Error Encountered when Creating or Modifying user Profile Policy
Administration
Okta Identity Engine
Overview
  • Admin sees the following error when adding policies.

Add user profile policy

Error message:


 We found some errors. Please review the form and make corrections.

Add user profile policy

 

  • Admin sees the following error when editing policies.

Error message:


 The rule could not be updated because the field firstName is hidden or read-only and cannot be added to the form.

Profile Enrollment
 
Applies To
Cause

The issue appears because one of the following Attributes has User Permission set to Read Only or Hide:

  •  First name
  •  Last name
  •  Primary email


Primary email screenshot 

The User permission for First name, Last name, and Primary email must be set to Read-Write before the Admin user can add a User Profile Policy.

 
Solution

To solve the issue, change the affected Attributes to Read-Write by performing the following steps:

  1. Navigate to the Admin console.
  2. Go to Directory > Profile Editor > User (default).
  3. Modify the value for User Permission for First name, Last name, and Primary email attributes from Read Only or Hide to Read-Write.

Primary email fixed screenshot

  1. Click Save Attribute.

 

Related References

 
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Error Encountered when Creating or Modifying user Profile Policy