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Error "Unable to fetch Workday users: Couldn't complete requests over extended period of time" when Running an Import from Workday
Okta Classic Engine
Okta Identity Engine
Lifecycle Management
Overview

Workday Import failed with the following error message:

 

Unable to fetch Workday users: Couldn't complete requests over extended period of time.

 

Applies To
  • Workday
  • Import
Cause

This issue happens when Okta waits for the information from Workday for 10 minutes (6,00,000ms) but does not receive it. After 10 minutes, Okta closes the import with an error message in the system logs: “Couldn't complete requests over extended period of time”.

Solution

Since the error was generated because Workday has not responded to Okta, please attempt the following steps:

  1. Review the Workday logs with the assistance of Workday Support to determine why Workday did not respond to Okta during that time.
  2. Verify any recent changes made in the Workday application.
  3. Make sure the service account permissions used for Okta-WD integration in Workday have not changed.
  4. Attempt a fresh import.


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Error "Unable to fetch Workday users: Couldn't complete requests over extended period of time" when Running an Import from Workday