<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Okta Access Gateway Invalid Domain Format Error Occurs When Configuring a Public Domain

Access Gateway
Okta Classic Engine
Okta Identity Engine

Overview

When configuring a public domain with a top-level domain longer than six characters for a new protected application, Okta Access Gateway generates an invalid domain format error. This occurs because the regular expression used in the domain validation rejects valid domains. Upgrade Okta Access Gateway to version 2023.11.0 or newer to resolve this issue. The following error message appears in the Public Domain field:

 

Invalid domain format. Requires e.g. domain.com

 

The following image displays the invalid domain format error message in the Okta Access Gateway interface.

Error Message

Applies To

  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • Okta Access Gateway (OAG) Release 2023.9.1 and Below
  • Public Domains With Top-Level Domains (TLDs)Longer Than Six Characters

Cause

The regular expression used in the domain validation generates an error for a valid domain.

Solution

How is the invalid domain format error resolved?

Upgrade Okta Access Gateway to version 2023.11.0 or newer.

Loading
Okta Access Gateway Invalid Domain Format Error Occurs When Configuring a Public Domain | Okta Support