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Error "Cannot be parsed because the user schema has been changed" when Viewing Users in Okta
Lifecycle Management
Okta Classic Engine
Okta Identity Engine
Overview

When trying to view a specific group of users under Directory > People, this message is shown instead of the user's profile:

Some users returned by the search cannot be parsed because the user schema has been changed to be inconsistent with their stale profile data.

 

Applies To
  • Universal Directory
  • Users
Cause

A mismatch is found between the currently affected user profiles and the Universal Directory attributes. Users were created with a different schema and had a different value type for some attributes that were later changed.

For example, the status attribute was created as a string, and the value active was set for these users. The status attribute was later changed to an array or recreated completely, so the users still have the value set as a string for the status attribute, which causes a mismatch.
 

Solution
  1. In order to fix this problem, Support will need to check the Okta logs for the attributes that are causing it. This will not show in the Okta System log, but a request ID taken from the browser's Developer Tools will help point Support to those attributes by checking in the backend logs.

  2. Export the browser logs and save the HAR file (it must be captured when the browser loads the window where the error is prompted). An HTTP 409 error will most likely be shown, which describes that a conflict has been found.

  3. Open a ticket with Okta Support, attaching the HAR file as well, and an investigation will start to see what is causing the mismatch.

 

Related References

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Error "Cannot be parsed because the user schema has been changed" when Viewing Users in Okta