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Error AADSTS700011 with Microsoft Office 365
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

The error below appears when OneDrive or SharePoint Online are accessed from the Microsoft Office 365 app within Okta.

 

AADSTS700011: Application with identifier https://tenant_name.onmicrosoft.com.sharepoint.com was not found in the directory.

 

Error message

 

Applies To
  • Microsoft Office 365
  • SharePoint
  • OneDrive
  • Single Sign-On
  • Typing specific extra values
Cause

This is caused by adding the .onmicrosoft.com to the Microsoft Tenant Name value from the General tab of the Microsoft Office 365 app within Okta. When authenticating with OneDrive and SharePoint, the app identifier generated is based on this value. Adding the .onmicrosoft.com part will send a resource identifier to Microsoft that does not exist.

Solution

Type in the correct value in the Microsoft Tenant Name field:


O365 General settings  


NOTE: Do not put onmicrosoft.com on that field, only the tenant's name.

After the change, it might not work, and still need to do the following steps to force a refresh on the application:

  1. Edit the apps and uncheck the SharePoint and OneDrive apps. Hit Save.
  2. Edit the apps and now check back the SharePoint and OneDrive apps. Hit Save.

Related References

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Error AADSTS700011 with Microsoft Office 365