/authorizeエンドポイントにリダイレクトされたときにエラー説明なしで[400 Bad Request]が発生する
Okta Classic Engine
Okta Identity Engine
API Access Management
Overview

ユーザーが/authorizeエンドポイントにリダイレクトされたときに、[400 Bad Request (不正なリクエスト)]が表示されます。詳細なエラーの説明はありません。

Applies To
  • OIDCアプリケーション
Cause

認証リクエストが無効です。これは、認証URL内またはOktaのアプリケーション設定内で設定ミスがあることが原因です。
指定したredirect_uriが認識されない場合と同様に、エラーページにエラーの説明が表示されない場合、通常はclient_idに問題があります。

Solution

考えられる原因と確認すべき点:

  • OIDCアプリケーションがOktaで[INACTIVE (非アクティブ)]に設定されている可能性があります。
    • テストしているアプリケーションが[ACTIVE (アクティブ)]に設定されていることを確認します。
  • 指定したclient_idが無効です。
    • 使用しているclient_idが、リクエスト先のOkta org(サブドメイン)に関連付けられていることを確認します。
    • client_idがOkta Admin Consoleに表示されるものと完全一致であることを確認します。OAuthではclient_idの大文字と小文字が区別されます。
    • client_idやその他の指定したパラメーターに余分なスペースが含まれていないことを確認します。

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