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Okta Verify TOTP Factor Enrollment via API is Not Returning SharedSecret Property in Response
Multi-Factor Authentication
Okta Identity Engine
Overview

Enrolling Okta Verify TOTP factor via Postman API is not returning SharedSecret Property in the Response when following the steps outlined in the Enroll a factor documentation.


Request example 

curl -v -X POST \
-H "Accept: application/json" \
-H "Content-Type: application/json" \
-H "User-Agent: Mozilla/5.0 (${systemInformation}) ${platform} (${platformDetails}) ${extensions}" \
-H "Authorization: SSWS ${api_token}" \
-d '{
  "factorType": "token:software:totp",
  "provider": "OKTA"
}' "https://${yourOktaDomain}/api/v1/users/00u15s1KDETTQMQYABRL/factors"


The below response is received in Postman:

{
    "errorCode": "E0000001",
    "errorSummary": "Api validation failed: factorEnrollRequest",
    "errorLink": "E0000001",
    "errorId": "oaew8DCrJsDTEi3HOTXXS1P5A",
    "errorCauses": [
        {
            "errorSummary": "This option is not supported for Okta Verify Push. Choose another to continue."
        }
    ]
}
Applies To
  • Okta Identity Engine (OIE)
  • Tenant migrating to OIE
  • Authentication Enrollment
Cause

This error message is caused by Okta Verify being set as Required in the Enrollment policy that applies to that user under Security > Authentication > Enrollment.

Solution
  1. Set Okta Verify under Security > Authentication > Enrollment as Optional in the policy that applies to that user.
  2. After that, try making the API call to enroll the factor again.

The error message should no longer be received and the enrollment of Okta Verify should be successful.

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Okta Verify TOTP Factor Enrollment via API is Not Returning SharedSecret Property in Response