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DocuSign Application Fails to Match Existing Okta Users During Assignment and Tries to Create New Ones
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Assigning an Okta user to the Okta Integration Network DocuSign application fails to match against an existing one, and the API tries to create a new user instead. The following errors are seen:

 

Automatic provisioning of user <user account> to app DocuSign failed: Matching user not found.


Automatic provisioning of user <user account> to app DocuSign failed: Error while trying to push profile update for <user account>. Username and email combination already exists for this account.

 

Applies To
  • DocuSign
  • Okta Integration Network (OIN)
  • SCIM provisioning
Cause

This issue is due to the username format matching against the one on the application side not being in an email format.

Solution

To resolve this issue, update the DocuSign application's Application Username format to ensure it generates an email-formatted value. This can be achieved by either matching against the Email field or by implementing a custom expression to convert the username accordingly.

Application username format

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DocuSign Application Fails to Match Existing Okta Users During Assignment and Tries to Create New Ones