<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Differentiating Access Request Types and Access Request Conditions in the Okta System Log

Okta Classic Engine
Identity Governance
Okta Identity Engine

Overview

When searching the System Log for updates, creations, or deletions of Access Request Types and Access Request Conditions, both events display the same event type of "Access Request Condition". This shared event type makes it difficult to distinguish between the two actions. To identify the correct event, review the "RawUserAgent" field in the System Log, which displays "Okta Inbox" for Access Request Types and "the computer agent" for Access Request Conditions.

Applies To

  • Okta Classic Engine
  • Okta Identity Engine (OIE)
  • Okta Identity Governance (OIG)
  • Okta Access Requests
  • System Log

Cause

Both Access Request Types and Access Request Conditions share the same event type designation in the System Log when an update, create, or delete action occurs: eventType co "access.request.condition".

 

NOTE: Request Conditions / Request Types can be disabled automatically if some type of resource is removed that the Request depends on for functioning. An email will be sent to the team if this occurs, prompting them to fix and re-enable the Access Request.

Solution

How are Access Request Types and Conditions distinguished in the System Log?

Navigate to the System Log, search for the event, and examine the Raw Agent field to identify the specific event type.

  1. Navigate to the System Log in the Okta Admin Console.
  2. Search for the relevant update, create, or delete event.
    • eventType co "access.request.condition"
  3. Expand the event details and locate the RawUserAgent field.
  4. Identify the event based on the following values:
    • Access Request Type: The RawUserAgent displays as "Okta Inbox".
    • Access Request Condition: The RawUserAgent displays as "UNKNOWN" and "What the computer agent currently is (Mac OS - Windows, for example)".

 

Example Screenshot of what RawUserAgent shows for events regarding an Access Request Condition (V2).
Access Request Condition

 

Example Screenshot of what RawUserAgent shows for events regarding an Access Request Types (V1).
RawUserAgent  

Loading
Okta Support - Differentiating Access Request Types and Access Request Conditions in the Okta System Log