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Denodo App SAML Login Fails with Error “Application has encountered an error. Please contact your support team”
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

After integrating Denodo as a SAML application, the only flow that works is the Service Provider (SP)-initiated flow. The Identity Provider (IdP)-initiated flow does not work and displays the following error:

Application has encountered an error. Please contact your support team.

 

Applies To
  • Denodo
  • Secure Assertion Markup Language (SAML)
  • Service Provider (SP) Flow
  • Identity Provider (IdP) Flow
Cause

This issue happens because the application provider does not support the IdP-initiated flow, only the SP-initiated flow.

Solution

This issue can be addressed by simulating the IdP-initiated flow using the steps below:

  1. Provide the SP login URL if known. Otherwise, reach out to the vendor for the SP login URL.
  2. Search for the Bookmark App within the Okta Integration Network (OIN) Catalog.
  3. Add Bookmark App.

Bookmark App

  1. Once added, open the Bookmark App and paste the SP login URL into the URL field.

Bookmark App's General Settings

  1. Utilize the newly created bookmark app and log in via the Okta Dashboard tile.

 

Related References

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Denodo App SAML Login Fails with Error “Application has encountered an error. Please contact your support team”