<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Deleting an Active Directory User from Okta
Directories
Overview

When an Okta user is deactivated, all of the user's applications are unassigned. Additionally, if the Profile and Lifecycle settings for that application are configured to deactivate the user when the Okta user is deactivated, Okta will perform a user deactivation in the downstream application.

 

Because Active Directory (AD) is an application integration, the same rule applies. Deactivating an Okta user will deactivate the downstream AD user.

Applies To
  • Directories
  • Active Directory
  • Provisioning
Cause

The Profile and Lifecycle settings that can deactivate (disable) an Active Directory account when the Okta user is deactivated cannot delete the user object.

Solution

The ability to delete an AD user object is not currently on the Okta Product Roadmap.

 

To submit this idea as a feature request/Idea for consideration in a future Okta update, please refer to the Okta Ideas Overview & FAQ page.

Loading
Deleting an Active Directory User from Okta