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Deleting a Custom IdP Factor Will Not Delete User Enrollments

Okta Classic Engine
Multi-Factor Authentication
Okta Identity Engine

Overview

When a custom IdP factor is deleted, this process will not delete/clear the user enrollments in this factor.

Applies To

  • Authentication factors
  • Custom IdP factor
  • Factor deletion/Enrollment clearance 

Cause

When completing the process of deleting a previously configured custom IdP factor, user enrollments will not be affected.

Admins can verify a user's enrollment via the UI interface or via API calls in Postman.

Via API, admins can use the List factors call to list all the enrolled factors for that user.

Via the UI interface, admins, using the admin console panel, can navigate to Directory > People > [choose desired user] > Reset factors. In the opening window, they can review the current factor enrollments.

Via the UI interface, the users themselves navigate to Okta Dashboard > My settings > Security methods.

Solution

A factor enrollment can be deleted via the UI interface or an API call in Postman.

Via API, they can use the Reset factor call to delete the factor for that user.

Via the UI interface, admins, using the admin console panel, navigate to Directory > People > [choose desired user] > Reset factors. Select the IdP factor and select Reset.

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Okta Support - Deleting a Custom IdP Factor Will Not Delete User Enrollments