Customized Email Templates Are Not Working with Okta's Default Email
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Overview
It is possible to customize and style the default email notifications that Okta sends to end users. Okta bases email notifications on templates that Okta generates automatically. The templates are available in each Okta-supported language. Use the default email templates or edit them to send custom messages to end users. End users receive emails based on the settings.
This article explains why Okta sends email notifications using the default email templates even though customized templates have already been defined.
NOTE: Okta successfully delivers test emails initiated from the Admin Console during email customization without a custom email domain. However, Okta requires a configured custom email domain to send customized emails in a production environment.
Applies To
- Email Templates
- Branding
Cause
To prevent phishing attacks, Okta requires orgs to have a custom email domain to send customized emails. All customized emails currently sent from the Okta domain are disabled, and orgs that use the Okta domain can send default email templates only. This feature is currently enabled by default for new orgs only.
The restrictions for email customizations are intended for new customer organizations.
Solution
A custom email domain must be configured to send customized emails (including branding, assets, etc.) to end users. Any changes made to the default email template will require the use of a custom email domain. Emails sent from Okta's default address (noreply@okta.com) will always use the unmodified default email template.
Please follow the steps provided in the How to Configure Custom Email Address for Branded Notifications article to configure a custom email domain.
