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Custom SAML App Signature Certificate Error "There was an unexpected error saving the file"
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

When uploading the public key Signature certificate required to validate the SAML sign-in request and the Single Logout (SLO) request for a custom SAML application, the following error appears in the Okta dashboard:

There was an unexpected error saving the file
 

error

Applies To
  • Custom SAML app
  • Single Sign-On (SSO)
  • Signature certificate
  • Secure Assertion Markup Language (SAML)
Cause

Okta is looking for the certificate with the formatting as shown in the screenshot below:

Certificate 
 

 
Solution

Please follow the video or the steps below: 


 

  1. Open the certificate in a text editor and update the certificate formatting, as shown in the screenshot above.
  2. Go to the Okta Admin panel and navigate to Applications > the Custom SAML app > General > SAML Settings > click Edit.
  3. On the Edit SAML Integration General Setting page, click Next > Configure SAML page. Select Show Advanced Settings > Signature Certificate.
  4. Click Browse files... and click Open to upload the certificate from the local system. The certificate will be uploaded successfully.

 

Related References

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Custom SAML App Signature Certificate Error "There was an unexpected error saving the file"