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Custom IdP Admin Role Cannot Edit Existing IdPs

Administration
Okta Classic Engine
Okta Identity Engine

Overview

A custom Admin Role with "Manage identity providers" permission cannot edit existing Identity Providers (IdPs).

Identity Providers

Applies To

  • Identity Provider (IdP)
  • Custom Admin Roles

Cause

The "Manage applications" permission is missing.

Solution

In order to enable editing of the IdP, give "Manage applications" permissions to the custom role:

  1. Navigate to Security > AdministratorsRoles tab.

Administrators

  1. Identify the custom role in question and click on the corresponding Edit button > Edit role.
  2. Search for the Manage applications permission and select it.

Edit Custom Role

  1. Once done, click Save Roles.
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Okta Support - Custom IdP Admin Role Cannot Edit Existing IdPs