Custom IdP Admin Role Cannot Edit Existing IdPs
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Overview
A custom Admin Role with "Manage identity providers" permission cannot edit existing Identity Providers (IdPs).
Applies To
- Identity Provider (IdP)
- Custom Admin Roles
Cause
The "Manage applications" permission is missing.
Solution
In order to enable editing of the IdP, give "Manage applications" permissions to the custom role:
- Navigate to Security > Administrators > Roles tab.
- Identify the custom role in question and click on the corresponding Edit button > Edit role.
- Search for the Manage applications permission and select it.
- Once done, click Save Roles.
