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Custom Admin Role is Unable to View or Manage Devices
Okta Identity Engine
Administration
Overview

A Custom Admin role with permission to Manage Devices generates the following error while viewing the devices page. 

 

You do not have permission to perform the requested action 

 

Applies To
  • Okta Identity Engine (OIE)
  • Custom Admin Role
Cause
  1. This is due to a resource set configuration issue.
  2. The resource set also needs to contain the resource for All Devices
  3. If the resource set is not added, the error below will be shown.
    1. Device Error
Solution

The issue can be solved by following the steps below.

  1. Log into the Admin Console.
  2. Navigate to Security > Administrators > Resource Set. 
  3. Edit the resource set and click Add another resource type, which is found under the existing Resources.
  4. Within the drop-down menu, find Devices and select All Devices.
  5. Device Resource Set
  6. Add the Resource and click Save
  7. Navigate to the Admins tab. 
  8. Click Edit > Edit Assignments.
  9. Modify the resource set for the Device Management Role to include the newly configured Resource Set.
  10. Click Save.
  11. Test the change by logging into the Administrator account on a different browser or Incognito window.

 

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Custom Admin Role is Unable to View or Manage Devices